Bug report #10882

Required option to set the default value(NULL) on date fields in QGIS 2.4

Added by Mahendiran Murugadoss almost 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Edit widget
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:19250

Description

In QGIS 2.4 there is no option to set the default values(NULL) on date fields in QGIS 2.4 if we have not updated any value on date fields. Its automatically taking the current system date. we are expecting to set the default values(NULL) for date fields in properties of layer, since we have to display the NULL values while capturing the new feature itself. It may be edited if required. Please refer the attached screen shots.

Date_Field_in_Layer_Properties.JPG (41.1 KB) Mahendiran Murugadoss, 2014-07-11 10:27 PM

Date_Field.JPG (84.4 KB) Mahendiran Murugadoss, 2014-07-11 10:27 PM

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Category changed from Attribute table to Edit widget
  • Status changed from Open to Feedback
  • Priority changed from High to Normal

Did it worked as expected in previous qgis versions?

#2 Updated by Mahendiran Murugadoss almost 6 years ago

Yes, it's automatically taking the value as NULL if we haven't updated any values on those date fields

#3 Updated by Giovanni Manghi almost 6 years ago

  • Priority changed from Normal to Severe/Regression

#4 Updated by Vasudevan Periasamy almost 6 years ago

+1.

Is it possible to provide a patch to this bug? I really need a work around for this. Thanks.

#5 Updated by Paolo Cavallini almost 6 years ago

Your best option is sponsoring its resolution. Ask if interested.

#6 Updated by Vasudevan Periasamy almost 6 years ago

What would be the cost (sponsor) for this fix?

#7 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

in QGIS master there is now an option "allow NULL values".

Also available in: Atom PDF