Bug report #10869

Processing: Import into PostGIS slow

Added by Paolo Cavallini about 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/QGIS
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:19237

Description

The tool is far slower than the old SPIT plugin, to the point that it cannot be an effective replacement for large data set. Perhaps the -D [Use postgresql dump format (defaults to SQL insert statements)] should be used?

History

#1 Updated by Victor Olaya about 6 years ago

I am not an expert on that. But if you reccomend that change, it looks like an easy thing. I will look at SPIT to see how it does it.

#2 Updated by Paolo Cavallini about 6 years ago

Please have a look to dbmanager too.

#3 Updated by Paolo Cavallini about 6 years ago

Correction: DB Manager is apparently equally slow

#4 Updated by Alexander Bruy over 5 years ago

  • Category changed from 94 to Processing/QGIS

#5 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Open to Feedback

Given the fast ogr based tools we will have in qgis 2.8 it could be useless to fix this.

#6 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to wontfix
  • Status changed from Feedback to Closed

I spoke with Paolo and he suggested to close this.

Also available in: Atom PDF