Bug report #10832

Bad Allocation when opening raster properties

Added by Julian O'Neill over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Jürgen Fischer
Category:Rasters
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19206

Description

Afternoon,

When trying to change the properties of the raster file (attached) I only ever receive a 'Bad Allocation' error. It is not possible to open the properties dialogue box. I have created many rasters in the same way as this one, which all work. I have tried to recreate this one, but it still causes the same error. Please note that I have changed the x and y coordinates as the data is potentially sensitive.

I expect there to be only values of -99 and 99 in the raster (null values are set to -999.0).

Your help would be much appreciated.

Kind Regards

BadAllocationGrid.zip (14 KB) Julian O'Neill, 2014-07-07 05:01 AM

Associated revisions

Revision 962a7d9f
Added by Jürgen Fischer over 5 years ago

avoid creating a histogram without range (fixes #10832)

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Subject changed from Bad Allocation - .asc properties to Bad Allocation when opening raster properties
  • Operating System deleted (Windows)
  • Priority changed from Normal to Severe/Regression
  • Category set to Rasters
  • OS version deleted (2.4)
  • confirmed on Windows and Linux
  • on Linux it seems to happen only if qgis is configured to render raster with the "cumulative count cut" option
  • it is not a .asc only issue, it happens the same if converting this raster as .tif
  • it does not happen on 2.2

#2 Updated by Giovanni Manghi over 5 years ago

  • Affected QGIS version changed from 2.4.0 to master

confirmed on the latest master.

#3 Updated by Jürgen Fischer over 5 years ago

  • Assignee set to Jürgen Fischer

#4 Updated by Jürgen Fischer over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF