Bug report #10775

Empty attribute dialog shown for memory layers

Added by Simon Kokkendorff over 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:-
Affected QGIS version:2.4.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:19157

Description

In the new QGIS 2.4 an empty attribute dialog is shown when adding a feature to a memory layer, which does not contain any fields. So you have to click OK in this empty dialog to proceed, which was not the case in QGIS 2.2.
Not sure if its a bug or a feature though :-)

empty_dialog.png (146 KB) Simon Kokkendorff, 2014-07-01 11:25 PM

Associated revisions

Revision ee68332e
Added by Nyall Dawson almost 5 years ago

Suppress attribute form popup if layer has no fields

Prevents empty form popup for layers with no fields (eg memory layers).
If desired, this behaviour can be overriden by the layer's feature
form suppress option, eg if form has python logic which makes it useful
even with no fields.

(fix #10775)

Revision c6581e72
Added by Nyall Dawson almost 5 years ago

Suppress attribute form popup if layer has no fields

Prevents empty form popup for layers with no fields (eg memory layers).
If desired, this behaviour can be overriden by the layer's feature
form suppress option, eg if form has python logic which makes it useful
even with no fields.

(fix #10775)

History

#1 Updated by Matthias Kuhn over 5 years ago

  • Status changed from Open to Closed

You can use the option "suppress attribute form..." option in layer properties/fields to get the same behavior.
We didn't want to forbid to show an empty dialog because there might be python logic in there (e.g. you could show coordinates on a r/o label).

#2 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to wontfix

#3 Updated by Paolo Cavallini almost 5 years ago

  • Status changed from Closed to Reopened

Better disable it by deafult, and let the user reenable it if add the Python logic.

#5 Updated by Nyall Dawson almost 5 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF