Bug report #10761

Preview modes not working

Added by Rhenriques Henriques about 6 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Canvas
Affected QGIS version:master Regression?:No
Operating System:Mac OSX and Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:19144

Description

The new colour preview modes (daltonism simulation) do not work under MacOSX - QGIS 2.4 and Night Build.

Associated revisions

Revision acc0f9b5
Added by Nyall Dawson almost 6 years ago

Disable preview modes under OSX due to issues with QGraphicsEffects under OSX (refs #10761)

Revision 5ecc9080
Added by Nyall Dawson almost 6 years ago

Disable preview modes under OSX due to issues with QGraphicsEffects under OSX (refs #10761)

History

#1 Updated by Giovanni Manghi about 6 years ago

  • Category set to Map Composer/Printing

#2 Updated by Paolo Cavallini about 4 years ago

  • Affected QGIS version changed from 2.4.0 to 2.14.2
  • Category changed from Map Composer/Printing to Map Canvas
  • Operating System changed from Mac OSX to Mac OSX and Win7

True also for win7 systems with a touchscreen, on QGIS 2.14.2

#3 Updated by Anita Graser almost 4 years ago

  • Affected QGIS version changed from 2.14.2 to master
  • Operating System changed from Mac OSX and Win7 to Mac OSX and Windows

Confirmed on Win10 QGIS 2.14.6 and master (OSGeo4W).

When changing to one of the preview modes, the map is not updating anymore (not automatically and not on interactions such as pan an zoom).

#4 Updated by Anita Graser almost 4 years ago

  • Subject changed from Preview modes not working in MacOSX to Preview modes not working

#5 Updated by Giovanni Manghi about 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#6 Updated by Tim Sutton almost 3 years ago

Fixed for MacOS under Qt 5.9 - see : https://github.com/qgis/QGIS/pull/4971

#7 Updated by Giovanni Manghi almost 3 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Also available in: Atom PDF