Bug report #10707

Renaming group item in composer legend resets all settings of sub items

Added by Miroslav Umlauf over 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:19100

Description

When you set up your categorized legend in composer and all tens of items rewrite to text you like, put in proper order etc. and at the end you find out you did typo in group name you are screwed. Renaming the group name resets all settings of sub items.

Affected 2.2 and master.

qgis_legend_01.png - Legend in layer properties (83.5 KB) Miroslav Umlauf, 2014-06-24 10:56 PM

qgis_legend_02.png - Adjusted legend in map/print composer (54.3 KB) Miroslav Umlauf, 2014-06-24 10:56 PM

qgis_legend_03.png - Reseted legend in map/print composer after changing group name (60.1 KB) Miroslav Umlauf, 2014-06-24 10:56 PM

desktop-cap-2014-06-26-1403773681.mp4 (3.5 MB) Giovanni Manghi, 2014-06-26 02:10 AM

History

#1 Updated by Nyall Dawson over 5 years ago

  • Status changed from Open to Feedback

I can't reproduce this ... can you please post detailed steps on how to trigger this issue?

#2 Updated by Miroslav Umlauf over 5 years ago

Sure, please find attached 3 new images.

#3 Updated by Giovanni Manghi over 5 years ago

  • Target version set to Version 2.4
  • Priority changed from Normal to Severe/Regression

Nyall Dawson wrote:

I can't reproduce this ... can you please post detailed steps on how to trigger this issue?

Hi Nyall,

I can see the issue and confirm that QGIS down to 2.0.1 is affected, 1.8 wasn't.

Do you want me to do a little screencast?

#4 Updated by Nyall Dawson over 5 years ago

Yes please - I still can't trigger this.

#5 Updated by Giovanni Manghi over 5 years ago

Nyall Dawson wrote:

Yes please - I still can't trigger this.

here it is

#6 Updated by Jürgen Fischer over 5 years ago

  • Target version changed from Version 2.4 to Future Release - High Priority

#7 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Feedback to Open

#8 Updated by Giovanni Manghi about 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

this seems solved in the latest master.

Also available in: Atom PDF