Bug report #10697

Browser does't show correctly and doesn't allow metadata (xml) preview

Added by A mulazzani almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Browser
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:19092

Description

QGIS Browser window doesn’t show correctly and doesn't allow metadata (xml) preview:
vector xml are shown with an icon normally used for raster and raster xml are shown with an icon normally used to represent a vector.
If you click on a metadata icon the following error message appears:

GDAL provider: Cannot open GDAL dataset C:/ROTAIE_VERDI/GIS_Rotaie_verdi/DATI_ORIGINALI/DATI_COMUNE_MILANO/CTC/ctc_ambiti_amministrativi/isolato.shp.xml: `C:/ROTAIE_VERDI/GIS_Rotaie_verdi/DATI_ORIGINALI/DATI_COMUNE_MILANO/CTC/ctc_ambiti_amministrativi/isolato.shp.xml' not recognised as a supported file format.
Raster layer: Sorgente dati non valida (sorgente dati: gdal, URI: C:/ROTAIE_VERDI/GIS_Rotaie_verdi/DATI_ORIGINALI/DATI_COMUNE_MILANO/CTC/ctc_ambiti_amministrativi/isolato.shp.xml

Thank you

per_topo.shp.xml Magnifier - vector xml (2.83 KB) A mulazzani, 2014-06-24 07:45 AM

ISS020-E-32424.tif.xml Magnifier - raster xml (7.09 KB) A mulazzani, 2014-06-24 07:45 AM

screenshot_raster.odt (361 KB) A mulazzani, 2014-06-24 07:45 AM

screenshot_vector.odt (379 KB) A mulazzani, 2014-06-24 07:45 AM

History

#1 Updated by Paolo Cavallini almost 6 years ago

  • Subject changed from Browser does't show correclty and doesn't allow metadata (xml) preview to Browser does't show correctly and doesn't allow metadata (xml) preview

#2 Updated by Giovanni Manghi almost 6 years ago

  • Category changed from Browser to 95

#3 Updated by Etienne Tourigny almost 6 years ago

  • Status changed from Open to Feedback

Does the same happen in the browser dock of the main qgis app?

Also can you upload here one example of raster and vector .xml files?

#4 Updated by A mulazzani almost 6 years ago

I actually noticed in the main qgis app browser, not in the stand alone one (somebody changed the category).
Anyway the same problem appears also in the standalone browser, where, if I attempt to open the xml (which always shows the raster icon), the browser crahes:
___________________________________________
Firma problema:
Nome evento problema: APPCRASH
Nome applicazione: qgis-browser-bin.exe
Versione applicazione: 0.0.0.0
Timestamp applicazione: 530de796
Nome modulo con errori: QtCore4.dll
Versione modulo con errori: 4.8.5.0
Timestamp modulo con errori: 530127d1
Codice eccezione: c0000005
Offset eccezione: 0000000000110f34
Versione SO: 6.3.9600.2.0.0.768.101
ID impostazioni locali: 1040
Informazioni aggiuntive 1: 11d9
Ulteriori informazioni 2: 11d9ac51abfdc8dda0af8973924a53ac
Ulteriori informazioni 3: a082
Ulteriori informazioni 4: a082e6eb66aa51be8081c0705e8ee0db
__________________________________________________________

Attached the two xmls and two screenshots

#5 Updated by Giovanni Manghi almost 6 years ago

  • Category changed from 95 to Browser

should those xml layer open correctly using the standard "add vector/raster" dialogs? They don't under Linux. So this may not be a browser issue after all.

#6 Updated by Etienne Tourigny almost 6 years ago

  • Target version set to Version 2.4

These metadata files are definitely NOT supported by QGIS nor gdal. When opening them via add vector/raster dialogs I get "unsupported data source" which is ok.

The .shp.xml files should NOT show up in the browser, and clicking on properties should not trigger a crash, so these are 2 bugs which should be fixed.

#7 Updated by Giovanni Manghi almost 6 years ago

Etienne Tourigny wrote:

These metadata files are definitely NOT supported by QGIS nor gdal. When opening them via add vector/raster dialogs I get "unsupported data source" which is ok.

The .shp.xml files should NOT show up in the browser, and clicking on properties should not trigger a crash, so these are 2 bugs which should be fixed.

so better change title and description of this ticket.

#8 Updated by Etienne Tourigny almost 6 years ago

  • Status changed from Feedback to Closed

fixed in changeset b261f57d0629851d6017b8973a5d637ea9e199b2 - they are not visible in the browser any more, and if they would be (e.g. any other *.xml file) the text "Error" appears in the metadata information.

If you want the information in these files to be available in the layer metadata, please file a feature request.

Also available in: Atom PDF