Bug report #10558

Unexpected interactions between labelling and diagrams

Added by Tim Sutton over 5 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:Larry Shaffer
Category:Labelling
Affected QGIS version:2.2.0 Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:18965

Description

I get some strange interactions between labels and diagrams. In particular:

  • Adding pi diagrams to my layer works, but for one area, no pie is rendered...
  • ...until I go and enable labelling in which case no labels render, but the missing pie chart shows ...
  • ...until I disable labelling in which case all pies are hidden...

I made a small screencast which illustrates this - I will add the link after submitting this ticket.

The sample dataset used in the screencasts is attached to this issue.

I am giving this issue `high` priority since currently pie and labels cannot be used together in the same layer.

jk.zip (92.6 KB) Tim Sutton, 2014-06-12 12:50 AM

History

#1 Updated by Tim Sutton over 5 years ago

Here is the screencast I made demonstrating some of the rendering issues.

http://www.youtube.com/watch?v=CGCy6Zkln8w

#2 Updated by Jürgen Fischer over 5 years ago

  • Target version changed from Version 2.4 to Future Release - High Priority

#3 Updated by Nyall Dawson over 4 years ago

  • Status changed from Open to Feedback

Can you test again with current master version? A lot of diagram related fixes have landed which should have solved this.

#4 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

seems fixed in the latest master, reopen if necessary.

Also available in: Atom PDF