Bug report #10402

QGIS master categorized symbology: column repeated

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:18818

Description

In QGIS master after selecting an attribute for a categorized symbology the choosen attribute column shows repeated when selecting the dropdown at a later time, see image
("campo2" is a column name that it is not repeated in the table of attributes)

Associated revisions

Revision 2d267f15
Added by Nathan Woodrow over 6 years ago

Fix #10402 - Don't duplicate combo items on selection

History

#1 Updated by Nyall Dawson over 6 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #10274

#2 Updated by Nathan Woodrow over 6 years ago

  • Status changed from Closed to Reopened

@Nyall this is something different.

#3 Updated by Nyall Dawson over 6 years ago

I don't think it is... the widget is showing the current 'expression' as the last value in the combo. If a single column has been selected, then the 'expression' is just the column name, so it looks like a duplicate. That's why I think showing this expression option in italics could help differentiate it. On the other hand, hiding it if it's a duplicate would work just as well!

#4 Updated by Nathan Woodrow over 6 years ago

Ahh I see what you mean. I think first try to find the field, if not assume it's an expression and add it to the bottom.

I will have a go now.

#5 Updated by Anonymous over 6 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF