Bug report #10345

New field calculator bar does not refresh values after update

Added by Alexandre Neto over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:Nathan Woodrow
Category:Attribute table
Affected QGIS version:master Regression?:No
Operating System:Ubuntu 12.10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18766

Description

Using the new field calculator bar, I have noticed that the values are not refreshed unless you scroll the attribute table down.

When you press the update button, nothing seems to have happen, making the user press more than once.

As soon as you scroll it, the values are updated


Related issues

Duplicated by QGIS Application - Bug report #10349: field calculator bar: clicking on 'update all' won't visu... Closed 2014-05-25

Associated revisions

Revision 20015e72
Added by Matthias Kuhn over 6 years ago

Attribute table: Fix repaint on change
Fix #10345

Revision ee770c4f
Added by Matthias Kuhn over 6 years ago

Better implementation of 20015e72
Fix #10345

History

#1 Updated by Matthias Kuhn over 6 years ago

Sounds more like an attribute table / layer cache problem than related to the expression bar. This does not need to do anything but updating and if you say that works, the problem is somewhere else.

#2 Updated by Mathieu Pellerin - nIRV over 6 years ago

Steps to reproduce this issue here #10349

#3 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF