Bug report #10224

Loading Geopackage sample crashes QGIS on Debian (works on Ubuntu and Windows)

Added by Paolo Cavallini about 6 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version:master Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:18669

Description

History

#1 Updated by Antonio Locandro about 6 years ago

confirmed Windows QGIS code revision afc2e05

#2 Updated by Jukka Rahkonen about 6 years ago

Seems to be fixed now in GDAL trunk and for version 1.11 http://trac.osgeo.org/gdal/ticket/5471#comment:1

#3 Updated by Giovanni Manghi about 5 years ago

  • Resolution set to not reproducable
  • Status changed from Open to Closed

not reproducable anymore.

#4 Updated by Paolo Cavallini about 5 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (not reproducable)

Still crashing here on deb, unclear if because of the spatialite packaging. Please leave it open for further testing after the resolution of that one.

#5 Updated by Giovanni Manghi about 5 years ago

Paolo Cavallini wrote:

Still crashing here on deb, unclear if because of the spatialite packaging. Please leave it open for further testing after the resolution of that one.

it works fine on Ubuntu and Windows.

#6 Updated by Giovanni Manghi about 5 years ago

  • Subject changed from Loading Geopackage sample crashes QGIS to Loading Geopackage sample crashes QGIS on Debian (works on Ubuntu and Windows)
  • Crashes QGIS or corrupts data changed from No to Yes
  • Affected QGIS version changed from 2.2.0 to master
  • OS version set to sid
  • Operating System set to Debian
  • Status changed from Feedback to Open

#7 Updated by Jürgen Fischer over 4 years ago

  • Resolution set to not reproducable
  • Status changed from Open to Closed

works fine here on unstable too.

Also available in: Atom PDF