Bug report #1017

QGIS crashes X session (Ubuntu Gutsy) if too many polygons are loaded

Added by tkeitt - over 12 years ago. Updated almost 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:-
Affected QGIS version: Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:11077

Description

I've noticed that more than 2000 or so polygons loaded into QGIS will cause X windows to crash.

History

#2 Updated by Paolo Cavallini over 11 years ago

Is this still valid? Many things are changed, please test it again and close it if appropriate.

#3 Updated by Paolo Cavallini over 11 years ago

See also #1430 (may be a duplicate)

#4 Updated by tkeitt - over 11 years ago

I have not tested this lately. It is not a QGIS bug. It is a bug in the Xserver. I have generated a backtrace and filed a bug with xorg. This (QGIS) bug can be closed because it does not occur in the QGIS code. The backtrace indicates that the bug is in the polygon filling algorithm used in X. As best I can tell that code was written at MIT in 1982!

#5 Updated by Paolo Cavallini over 11 years ago

  • Status changed from Open to Closed
  • Resolution set to invalid

#6 Updated by Anonymous almost 11 years ago

Milestone Version 1.0.2 deleted

Also available in: Atom PDF