Bug report #10138

Crash in svg cache with svg symbols

Added by Luca Mandolesi over 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Symbology
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:18597

Description

When you open a qpt realized with a scalebar inside, the scale may crash QGIS. In more cases this happen from a version to another, but sometime it happen also inside the same version.
It happens under Windows and Linux.

A3_prova.qpt - qpt created with qgis 1.8, it crushes with qgis 2.2 (19.7 KB) Luca Mandolesi, 2014-04-29 05:15 AM

tracback.rtf - error traceback (2.99 KB) Luca Mandolesi, 2014-04-29 05:15 AM

History

#1 Updated by Paolo Cavallini over 6 years ago

  • Assignee deleted (Nyall Dawson)
  • Subject changed from Map composer crush because of scalebar to Map composer crashes because of scalebar
  • Category set to Map Composer/Printing

#2 Updated by Nyall Dawson over 6 years ago

  • Category changed from Map Composer/Printing to Symbology
  • Subject changed from Map composer crashes because of scalebar to Crash in svg cache with svg symbols

This isn't actually a composer/scalebar related bug. It's caused by the svg fill patterns shown in the legend - the svg cache is crashing. Reassigning to symbology.

#3 Updated by Giovanni Manghi about 6 years ago

  • Priority changed from Normal to High

#4 Updated by Giovanni Manghi about 6 years ago

  • Status changed from Open to Feedback

cannot replicate on master, still true?

#5 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to not reproducable

closing for lack of feedback. Reopen if necessary.

Also available in: Atom PDF