Bug report #9882

QGIS 2.2.0.1 Valmiera, Windows 7 64 bit - copying out of GDALInfo-Window in QGIS not possible

Added by Lars Scharfenberg over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18403

Description

When trying to copy information given out by GDALInfo with different kinds of raster data (DEM, normal georeferenced images etc.) through the interface of QGIS 2.2 by right-clicking and choosing copy (I want it in the clipboard) a Python error message keeps appearing. The steps to get this error are as follows: I go over Raster - Miscellaneous - Info in the menu bar. Then I right click the information that's shown in the resulting window and choose "copy all" or "copy". It's basically the equivalent of the QGIS GUI to entering gdalinfo and the location of the raster in the OSGEO4W shell. Only solution is to either enter all data manually in the program i want it in, or to use the OSGEO4W shell and copy the info about the raster from there (since it's not possible to do that out of properties of raster data in QGIS). This is the error message that shows up every time I try, was like this in QGIS 2.0, and it hasn't changed in 2.2:

Fehler bei der Ausf├╝hrung von Python-Code:
Traceback (most recent call last):
File "C:/PROGRA~2/QGISVA~1/apps/qgis/./python/plugins\\GdalTools\\tools\\doInfo.py",
line 73, in doCopyLine
output.append( r.text() + "\
" )
AttributeError: 'str' object has no attribute 'append'
Python-Version:
2.7.4 (default, Apr 6 2013, 19:54:46) [MSC v.1500 32 bit (Intel)]
QGIS-Version:
2.2.0-Valmiera Valmiera, c3a2817
Python-Pfad: ['C:/PROGRA~2/QGISVA~1/apps/qgis/./python/plugins\\\\processing',   
'C:/PROGRA~2/QGISVA~1/apps/qgis/./python', u'C:/Users/Lars/.qgis2/python', u'C:/Users
/Lars/.qgis2/python/plugins', 'C:/PROGRA~2/QGISVA~1/apps/qgis/./python/plugins',
'C:\\\\PROGRA~2\\\\QGISVA~1\\\\bin\\\\python27.zip', 'C:\\\\PROGRA~2\\\\QGISVA~1\\\\apps\\\\Python27
\\\\DLLs', 'C:\\\\PROGRA~2\\\\QGISVA~1\\\\apps\\\\Python27\\\\lib', 'C:\\\\PROGRA~2\\\\QGISVA~1\\\\apps
\\\\Python27\\\\lib\\\\plat-win', 'C:\\\\PROGRA~2\\\\QGISVA~1\\\\apps\\\\Python27\\\\lib\\\\lib-tk',
'C:\\\\PROGRA~2\\\\QGISVA~1\\\\bin', 'C:\\\\PROGRA~2\\\\QGISVA~1\\\\apps\\\\Python27', 'C:\\\\PROGRA~2
\\\\QGISVA~1\\\\apps\\\\Python27\\\\lib\\\\site-packages', 'C:\\\\PROGRA~2\\\\QGISVA~1\\\\apps
\\\\Python27\\\\lib\\\\site-packages\\\\PIL', 'C:\\\\PROGRA~2\\\\QGISVA~1\\\\apps\\\\Python27
\\\\lib\\\\site-packages\\\\win32', 'C:\\\\PROGRA~2\\\\QGISVA~1\\\\apps\\\\Python27\\\\lib\\\\site-
packages\\\\win32\\\\lib', 'C:\\\\PROGRA~2\\\\QGISVA~1\\\\apps\\\\Python27\\\\lib\\\\site-packages
\\\\Pythonwin', 'C:\\\\PROGRA~2\\\\QGISVA~1\\\\apps\\\\Python27\\\\lib\\\\site-packages\\\\Shapely-
1.2.18-py2.7-win32.egg', 'C:\\\\PROGRA~2\\\\QGISVA~1\\\\apps\\\\Python27\\\\lib\\\\site-packages
\\\\wx-2.8-msw-unicode', 'C:\\\\PROGRA~2\\\\QGISVA~1\\\\apps\\\\qgis\\\\python\\\\plugins\\\\fTools
\\\\tools']

Associated revisions

Revision cd9aae70
Added by Alexander Bruy over 5 years ago

fix error when copying gdalinfo output to clipboard (fix #9882)

History

#1 Updated by Alexander Bruy over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF