Bug report #9881

Improve GUI consistency & UX for data-defined style

Added by Anita Graser over 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:Mathieu Pellerin - nIRV
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18402

Description

The GUI for data-defined settings is currently not consistent between style and label window: in the style window, there is an extra button to set data-defined settings. It is not possible to see directly which settings are data-defined.

The solution in the label window is better UX-wise: There is a dedicated button besides every option which can be data-defined. On mouse-over, there is a short help. On click, it's possible to directly chose the column which should be used. If data-defined settings are active, the button/icon is highlighted.

I think the label solution should be applied to the style window as well.

original discussion: http://osgeo-org.1560.x6.nabble.com/Duplication-of-functionality-Data-defined-size-and-Size-scale-field-td5131007.html

style_now.png (143 KB) Anita Graser, 2014-03-26 02:30 AM

label_now.png (139 KB) Anita Graser, 2014-03-26 02:30 AM

can_not_reproduce.png (124 KB) Vincent Mora, 2015-01-21 11:12 PM

Associated revisions

Revision 6fb347d2
Added by Vincent Mora almost 6 years ago

improve GUI consistency & UX for data-defined style

data defined buttons added to the gui
fixes #9881

History

#1 Updated by Vincent Mora almost 6 years ago

  • Assignee set to Vincent Mora

#2 Updated by Vincent Mora almost 6 years ago

  • Pull Request or Patch supplied changed from No to Yes

#3 Updated by Vincent Mora almost 6 years ago

  • Status changed from Open to Closed

#4 Updated by Vincent Mora almost 6 years ago

  • Status changed from Closed to Reopened

There is a size problem reported by nirvn here #6fb347d23fd1530834053aab9500ea4087e4335c#commitcomment-9389732

I'm on it.

#5 Updated by Vincent Mora almost 6 years ago

  • File can_not_reproduce.png added
  • Assignee changed from Vincent Mora to Mathieu Pellerin - nIRV
  • Status changed from Reopened to Feedback

But I cannot reproduce with a fresh master (see attached)

#6 Updated by Nathan Woodrow almost 6 years ago

Nyall has already fixed it :)

#7 Updated by Vincent Mora almost 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF