Bug report #9867

Advanced Python field calculator needs documentation

Added by Anita Graser over 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:High
Assignee:Victor Olaya
Category:Processing/QGIS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:18394

Description

Since the syntax is not standard QGIS field calculator syntax, users definitely need documentation here.

I've written down some notes
... especially that you have to put attribute names in pointy brackets is tricky.

History

#1 Updated by Alexander Bruy over 5 years ago

Well, I agreed that this tool has different syntax in compare to QGIS Field calculator, but algorithm help files and documentation AFAIK located in special repository https://github.com/volaya/Processing-Help

#2 Updated by Anita Graser over 5 years ago

That's great if there is documentation on Github. Can we bring it into the plugin?

#3 Updated by Alexander Bruy over 5 years ago

I don't know about Victor's plans regarding it. I think it will go into plugin at some point, but first we should write docs, because for most algorithms only template file is available.

TauDEM is documented, some of the QGIS algorithms too. Not sure about others

#4 Updated by Antonio Locandro over 5 years ago

Hi All, I spent almost a week wondering why things didn't work.

Here is my point of view, really processing should use QGIS Field calculator syntax and if possible bring it as a whole (most of GUI) so the user has the same experience across QGIS, having a different syntax adds a complexity of its own specially if it has no associated help - Sorry, no help is available for this algorithm. -

I am not to keen on using a different syntax since it makes it more difficult to work with than it should, in the mean time, can someone at least add a link to open instead of - Sorry, no help is available for this algorithm. -

#5 Updated by Jürgen Fischer almost 5 years ago

  • Subject changed from Processing - Advanced Python field calculator needs documentation to Advanced Python field calculator needs documentation

#6 Updated by Alexander Bruy almost 5 years ago

  • Category changed from 94 to Processing/QGIS

#7 Updated by Alexander Bruy almost 5 years ago

  • Status changed from Open to In Progress

Now documentation for Processing algs included in User Guide

#8 Updated by Alexander Bruy almost 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from In Progress to Closed

Now Processing used help from User Guide. Reopen if necessary

Also available in: Atom PDF