Bug report #9856

pyqgis cookbook documentation need updating (was setColorShadingAlgorithm missing for QsgRasterLayer)

Added by Nicola Stella almost 6 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Documentation and Help
Affected QGIS version:2.2.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18384

Description

In QGIS 2.2.0.

setColorShadingAlgorithm missing for QsgRasterLayer

History

#1 Updated by Etienne Tourigny almost 6 years ago

  • Category set to Documentation and Help
  • Subject changed from setColorShadingAlgorithm missing for QsgRasterLayer to pyqgis cookbook documentation need updating (was setColorShadingAlgorithm missing for QsgRasterLayer)

This is not a bug, but a change in the API.

You should use setRendererForDrawingStyle() or setDrawingStyle()

Please see the API page for QgsRasterLayer for further details.

However, the pyqgis cookbook should be updated, as it refers to setColorShadingAlgorithm()

#2 Updated by Alexander Bruy almost 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF