Bug report #9829

Copy paste from one layer (anyformat) to another (shape) kills attributes in qgis 2.2

Added by Gilles V about 6 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:2.2.0 Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:18360

Description

two layers with identical fields, say in dxf, let's call them A and B. Some fields have a name longer than ten chars.
One other layer, called C, created by saving A as shapefile.

The goal is now to copy paste all entities from B to C, so in the end I only have one layer with all data.

C in edition mode.
Selection of all entities in B, copy, paste in C, save C.

Problem : all attributes of the pasted entities are lost in version 2.2. NULL in every field.
In version 2.1, only the truncated fields (due to the ten chars limitation of shp) would be written NULL.

So it is actually worse in 2.2.

1. Could we get back the ability to at least correctly past attributes in the fields not truncated,
2. Could we gat the option (tickbox ?...) to force the copy of all attributes even if the field name is truncated in the shp ?

Thank you.

History

#1 Updated by Gilles V about 6 years ago

Simple entity copy from shp layer A to shp layer B, it won't copy entity's attributes in point layer.
It works with 2.0 dufour.
It's definitely a 2.2 valmiera problem.

#2 Updated by Jürgen Fischer almost 6 years ago

  • Category set to Vectors

#3 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Open to Feedback

still true on the latest master? can you attach sample data? Thanks.

#4 Updated by Jürgen Fischer almost 6 years ago

  • Target version changed from Version 2.2 to Future Release - Lower Priority

#5 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to worksforme

just tested and works as expected on the latest master.

#6 Updated by Jakub Kosik over 2 years ago

How to say... Problem is so old, but still presist in 2.14.16 But problem is "intermittent" - sometimes work as expected, other total attribute loss.
Any ideas?
In my case there are two identical structure sqlite databases, same tables and columns.

#7 Updated by Giovanni Manghi over 2 years ago

  • Description updated (diff)

Jakub Kosik wrote:

How to say... Problem is so old, but still presist in 2.14.16 But problem is "intermittent" - sometimes work as expected, other total attribute loss.
Any ideas?
In my case there are two identical structure sqlite databases, same tables and columns.

please attach sample data.

Also available in: Atom PDF