Feature request #9819

Dynamic legend based on canvas extent

Added by John Tull over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No

Description

The Atlas tool has greatly enhanced the print composer functionality of QGIS. Using it has brought to mind a feature that would be very useful if it could be implemented: dynamic composer legends.

With dynamic composer legends, mapped layers that have no features in the composer canvas would not appear in the legend, whereas items visible would appear in the legend. This would be useful for applications where multiple maps are generated for a mapped area, but not all data layers show up in each map composer, whether mapped manually or generated with the Atlas tool.

The value of these dynamic legends is having maps that don't include symbology in the map legend for layers that are not present in the map. This is confusing for those using the map, and it necessitates producing maps manually that you would like to be able to generate with the Atlas tool if you want to generate legends that represent actual data on each map.

History

#1 Updated by Nyall Dawson over 3 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #3121

Also available in: Atom PDF