Bug report #9787

hanging / memory leak when moving large numbers of points

Added by Gavin Fleming over 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:18329

Description

QGIS 2.3 master

I have a layer with 40000 points that I need to move. If I move a few at a time it works but even just a few thousand, QGIS and PostGIS go into overdrive and I have to kill QGIS eventually.

History

#1 Updated by Jürgen Fischer over 5 years ago

  • Category set to Digitising

#2 Updated by Giovanni Manghi over 5 years ago

  • Crashes QGIS or corrupts data changed from No to Yes
  • Affected QGIS version changed from 2.2.0 to master
  • OS version deleted (13.10)
  • Target version set to Future Release - High Priority
  • Priority changed from Normal to High
  • Operating System deleted (ubuntu)

still an issue on latest master and even on high end machines.

#3 Updated by Giovanni Manghi about 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #11197 (and fixed).

Also available in: Atom PDF