Bug report #9641

on qgis master (2.3) 1-band raster rendering in grayscale with contrast enhancement is semi-broken

Added by Mathieu Pellerin - nIRV about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Martin Dobias
Category:Rasters
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18213

Description

In qgis master (2.3), 1-band raster rendering in grayscale with contrast enhancement produces visual artifacts all over the place. See attached screenshots comparing proper rendering (under 2.2) and broken rendering (under 2.3).

Steps to reproduce:
1. Load the attached tatam.tif raster
2. If your default setting enables contrast enhancement, you should already see artifacts, otherwise continue with the remaining steps
3. Open the layer property window, and go to the style tab
4. Make sure the settings are as follow:
-- Rendering type: singleband gray
-- Color gradient: black to white
-- Min: 65.7422
-- Max: 222.129
-- Contrast enhancement: Stretch to MinMax
5. Apply those settings to make the artifacts appear
6. You can disable/enable the contrast enhancement to see the proper vs broken rendering

This must be caused by the multi-threading rendering, can't see anything else between 2.2 and 2.3 that could cause this.

hillshade-raster-qgis2.2-ok.png (294 KB) Mathieu Pellerin - nIRV, 2014-02-24 06:09 PM

hillshade-raster-qgis2.3-broken.png (305 KB) Mathieu Pellerin - nIRV, 2014-02-24 06:09 PM

tatam.tif (839 KB) Mathieu Pellerin - nIRV, 2014-02-24 06:09 PM

Associated revisions

Revision 71a799f0
Added by Martin Dobias about 6 years ago

Fix #9641 (broken contrast enhancement)

History

#1 Updated by Nathan Woodrow about 6 years ago

  • Tag set to MTR

#2 Updated by Martin Dobias about 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF