Bug report #9634

Oracle not working at all

Added by Jonathan Moules over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18206

Description

Using 2.2.0 from the OSGeo4W.
Clicking on the Oracle provider button brings up a dialog:
"Cannot get Oracle select dialog from provider."

I've uninstalled and re-installed, still get it. It worked fine with the weekly build from a > month ago that I was using.

(Also, "Affected version" on this tracker doesn't have a "2.2.0" yet.)


Related issues

Related to QGIS Application - Feature request #9636: Oracle provider dialog improvement Open 2014-02-24

History

#1 Updated by Jürgen Fischer over 6 years ago

32 or 64bit? Is qgis-oracle-provider-2.2.0-1 installed?

#2 Updated by Jonathan Moules over 6 years ago

64bit. Installed on a Windows 7 64bit machine.

I just used whatever the OSGeo4W defaults were.
There doesn't seem to be any file with "qgis-oracle" in the name anywhere.

I see that OSGeo4W doesn't seem to include it by default. I'm sure it used to? Never had this problem before.
I'm downloading the package now.

#3 Updated by Jürgen Fischer over 6 years ago

  • Status changed from Open to Closed

Ah, ok - so you probably installer just qgis.

qgis-oracle-provider (and in turn the large oci package) is an optional dependency, if you want it you need to explictly install it or install qgis-full (that's also what the QGIS entry in the non-advanced install targets to), which will pull in qgis and a bunch of optional stuff (like support for oracle, ecw, mrsid, filegdb and python extensions external plugins use).

#4 Updated by Jonathan Moules over 6 years ago

Confirmed. It works now that I've downloaded and installed that too.

I'd missed that there's a "QGIS Desktop" AND A "QGIS Full Desktop". I guess I installed it a different way before in this.
Sorry for the noise. Thanks.

Also available in: Atom PDF