Bug report #9618

Make httplib2 an external dependency

Added by Matthias Kuhn about 6 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:18192

Description

When building packages for Fedora I noticed that currently httplib2 is shipped with QGIS. The Fedora package maintainers patched QGIS to use the httplib2 version from their repository. To bring these packages closer to upstream (and therefore make maintenance easier) I think it would be best to adjust this.
Therefore I'd like to ask if there is any reason for shipping httplib2 internally (and therefore Fedora should just ship with the version that comes with QGIS) or if we can totally drop this from our sources or if it is just required for certain platforms and a new CMAKE option could be introduced (WITH_INTERNAL_HTTPLIB2) which can then be turned on/off depending on the target system.
Victor, I'm assigning this to you for feedback as it seems to be only used in processing.

Associated revisions

Revision be8ae5fb
Added by Matthias Kuhn about 6 years ago

Add new CMake option: WITH_INTERNAL_HTTPLIB (default True)

If set to False, you have to make sure that the httplib2 package
is available on the target platform

Fix #9618

History

#1 Updated by Etienne Tourigny about 6 years ago

python dependencies are not always easily installed - especially in mac...
Adding this dependency would require packages for all platforms, although one exists for ubuntu.
Probably easier to add an option for internal vs. external, based on the Fedora patch.

#2 Updated by Alexander Bruy about 6 years ago

  • Affected QGIS version changed from 2.0.1 to master
  • Pull Request or Patch supplied changed from No to Yes

Here is pull-request that fixes this https://github.com/qgis/QGIS/pull/1235

#3 Updated by Alexander Bruy about 6 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Applied in 36bd2d000a

#4 Updated by Giovanni Manghi almost 5 years ago

  • Category changed from 94 to Processing/Core

Also available in: Atom PDF