Feature request #9591

Oracle connection to use metadata table for extent

Added by Jonathan Moules about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:Data Provider/Oracle
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No Copied to github as #:18171

Description

Currently when adding an Oracle layer QGIS performs a MBR check against the layer (SDO_TUNE.EXTENTS_OF). This hangs QGIS for several minutes if the table is a large one (millions of rows) and/or/especially if there are multiple tables.

An approximate MBR is already held in the MDSYS.USER_SDO_GEOM_METADATA - this should be used instead.

I'd suggest assigning it to "use estimated table metadata" checkboxes so people who want the exact boundaries (i.e. those who don't keep their GEOM up to date) can use those instead.


Related issues

Duplicates QGIS Application - Feature request #8850: Oracle not looking in USER_SDO_GEOM_METADATA for extents Closed 2013-10-15

History

#1 Updated by Jürgen Fischer about 6 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #8850

#2 Updated by Jonathan Moules about 6 years ago

Good catch, thanks.
Because the issue is still happening I figured I hadn't reported this particular thing before. I've posted an update to the original ticket which may need to be re-opened.

Also available in: Atom PDF