Bug report #9581

linestrings not transforming on the fly

Added by Gavin Fleming over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:-
Affected QGIS version:2.0.1 Regression?:No
Operating System:ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:18164

Description

QGIS Master 2.2 (from debian-nightly). This has happened with linestrings from various sources (shapefile, gpx and postgis)

Linstrings draw in their own CRS but when the project CRS is changed, they do not render. Other feature types render fine, but the linestrings stop rendering. Set the CRS back to the layer's own CRS and they render again.

hotel_airport.zip (22 KB) Gavin Fleming, 2014-02-18 12:15 PM

History

#1 Updated by Gavin Fleming over 5 years ago

appears to be duplicate of #9360

#2 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Open to Feedback

Gavin Fleming wrote:

appears to be duplicate of #9360

as it happens for #9360 I'm really not able to replicate (using master on Ubuntu installed from repo).

Can you attach sample data? What your "about" dialog says?

#3 Updated by Gavin Fleming over 5 years ago

Try the attached shapefile. If I load it with simplification on, it never draws when projected but if I load it with simplification off it always draws when projected.

About:
QGIS version 2.1.0-Master QGIS code revision exported
Compiled against Qt 4.8.4 Running against Qt 4.8.4
Compiled against GDAL/OGR 1.9.0 Running against GDAL/OGR 1.9.0
Compiled against GEOS 3.3.3-CAPI-1.7.4 Running against GEOS 3.3.8-CAPI-1.7.8
PostgreSQL Client Version 9.1.10 SpatiaLite Version 3.1.0-RC2
QWT Version 5.2.3 PROJ.4 Version 470
QScintilla2 Version

#4 Updated by Richard Duivenvoorde over 5 years ago

Gavin, I cannot reproduce this either (Debian self compiled QGIS of yesterday)

Loading your (latlon degrees) shapefile over an OpenLayers Google Streetmap layer loads fine. Both with and without simplification.
I also tried different styles.

Can you maybe provide a test project file (foo.qgs), maybe you have strange styles or other settings (like for the rendering)?

If you select (zoom to layer extent), do you go to the right place (Windhoek namibia)?

Do you see any debugging information if you start QGIS from command line?

#5 Updated by Mathieu Pellerin - nIRV over 5 years ago

Richard, there's a serious ongoing issue with simplification that only manifests through debian-nightly packages (but not on self-compiled qgis master).

Gavin, a developer has commited a change that might improve situation (#dc50304f52f016cd220618676a7fff10bf16a107). Give it a try when debian-nightly packages are updated.

#6 Updated by Martin Dobias over 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed/implemented

I am pretty sure this got fixed by 5d4cf3086 (same problem with randomly overwritten extent)

#7 Updated by Martin Dobias over 5 years ago

  • Target version set to Version 2.2

Also available in: Atom PDF