Bug report #9580

wrong geometry error detection with QGIS method

Added by Otto Dassau almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18163

Description

Hi,

attached you find a small project with a polygon shape file. Using the "check geometry validity" tool from the fTools plugin and selecting the "QGIS" method to validate geometries under Settings -> Options -> Digitizing there is following error: "segments of line intersect at ...:

You can see the place with the red cross in the attached figure, where the error occurs in the qgis project. The problem is, that the boundary of the polygon touches at that point but does not intersect. In my opinion this happens quite often and should not be an error. Furthermore it causes problems, because other geometry tools cannot be used, if you e.g. try to split that polygon. Can someone explain, why this is handled as an error by the validate geometries option "QGIS", but not if I use "GEOS" as method? And can this be changed?

Thanks a lot
Otto

geometry_error.png (86.1 KB) Otto Dassau, 2014-02-17 06:11 AM

test_bereich1.zip (7.44 KB) Otto Dassau, 2014-02-17 06:11 AM

Associated revisions

Revision b9b9bc31
Added by Jürgen Fischer almost 6 years ago

geometry validation: don't consider touching lines as intersection (fixes #3851, fixes #7501, fixes #9580)

History

#1 Updated by Jürgen Fischer almost 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF