Bug report #9572

legend of categorized renderer of layers with joins incorrect

Added by Antonio Valanzano almost 7 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:18155

Description

I have noticed a not correct display of categorized type legend using
joined fields.
If I use one of the joined field for the legend then QGIS shows all the
values of the joined table and not only the values which are present in the
main table after the join.

History

#1 Updated by Jürgen Fischer almost 7 years ago

  • Subject changed from legend to legend of categorized renderer of layers with joins incorrect

#2 Updated by Giovanni Manghi almost 7 years ago

  • Affected QGIS version changed from 2.0.1 to master
  • Target version set to Version 2.2
  • Category set to Symbology

Confirmed on master.

#3 Updated by Jürgen Fischer over 6 years ago

  • Target version changed from Version 2.2 to Future Release - Lower Priority

#4 Updated by Nyall Dawson over 4 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

Duplicate of #9051

Also available in: Atom PDF