Bug report #9568

Rubberband bug if zooming in or out during nodetool edition

Added by Leyan Ouyang almost 7 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:18151

Description

I often have to zoom in or out during edition, either to see a larger area or to place a point more precisely and avoid snapping. I use the mouse wheel to do it while keeping the mouse button pressed in order not to release the node I am currently moving.

In that case, there is an offset between the main blue rubberband and the mouse. However, the red rubberband from topology edition manages to follow the cursor. The blue rubberband also gets at the correct position when snapping to a vertex or segment.

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#2 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Open to Feedback

Please test with a recent QGIS release (2.18 or 3), if the issue/request is still valid change the affected version accordingly, if is fixed/implemented then close the ticket. Thanks!

#3 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed
  • Description updated (diff)

Closing for lack of feedback.

Also available in: Atom PDF