Bug report #9548

can't load as new layer from sql in dbmanager error

Added by Nyall Dawson over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:DB Manager
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:18135

Description

Since the recent change in syntax highlighting, it's impossible to retrieve columns or load a layer when "load as new layer" is ticked. The error is:

File "C:/OSGeo4W/apps/qgis-dev/./python/plugins\\db_manager\\dlg_sql_window.py", line 202, in fillColumnCombos
query = self.getSql()
AttributeError: 'DlgSqlWindow' object has no attribute 'getSql'

Associated revisions

Revision 57dd8779
Added by Jürgen Fischer over 7 years ago

dbmanager: fix 'load as new layer' (fixes #9548)

History

#1 Updated by Jürgen Fischer over 7 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF