Bug report #9499

path to external-svg-folder or storage of svg

Added by Marianne Wargenau over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:18090

Description

I tried to assign QGIS the path to my svg (in german: Layereigenschaften - Stil - Symbollayertyp is set to SVG-Markierung). However there is no such possibility to assign a path to a folder, which is very annoying. If I copy my symbols in the folder C:\\Program Files\\QGIS Dufour\\apps\\qgis\\svg (this is where the svg from QGis are stored), the folder does not appear (same with single symbols).
Right below 'SVG-Gruppen' there is a folder tree with two main folders: 'App Symbols' and 'User Symbols', of which the latter seems to be set for this purpose.

It is urgently needed that paths to svg folders are accepted and stored. Or that users can save their own svg in a folder.

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

If there was an issue this is now fixed in qgis master. I tested on both Linux and Windows and you can add path to folders containing SVG symbols in

settings > options > system > svg paths

the new symbols then show in a "svg" category in the symbology dialogs.

Also available in: Atom PDF