Bug report #9494

Browser - Edit - doesn't work for OWS services

Added by Jonathan Moules over 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Browser
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:18085

Description

I have a number of OGC services set up and accessible via the Browser.

If I right-click on the name of a service for WMS or WFS or WCS, I get the standard interface dialog.

However, if I right click on any of the same layers in the OWS list, the "Edit" function doesn't work.

5192e8d

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Target version set to Version 2.2

#2 Updated by Richard Duivenvoorde about 6 years ago

Same for the 'delete' option: also working for wms/wfs/wcs but not for ows

#3 Updated by Jürgen Fischer almost 6 years ago

  • Target version changed from Version 2.2 to Future Release - Lower Priority

#4 Updated by Radim Blazek over 5 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

There is no "real" OWS services list stored in QGIS settings, what you see in the browser is just mix of layers from W*S services with the same name. It is not possible to open any OWS edit dialog because there is no such dialog in QGIS. In theory it would be possible to delete all W*S of the same name from OWS tree section, but it seems too dangerous to me.

Also available in: Atom PDF