Bug report #9394

Non-'Single Symbol' styles hide the layer in Master

Added by Simon Dedman almost 6 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:17992

Description

Hi all,

I've just posted this problem on gis.stackexchange here , after having a similar problem here .

In brief: in QGis master, csv files (and polygons e.g. voronoi built off them?) disappear when styles other than 'single symbol' are selected. Also (diagnostically?) a blank-named column field is present at the end of the list of candidate columns upon which to base the style. In DuFour, neither of these problems are present (please see above links for pictures which explain this better; pictures also attached here).

QGis master Cheers.

Simon

csv_graduated_bug.png (169 KB) Simon Dedman, 2014-01-21 02:58 AM

csv_graduated_bug2.png (158 KB) Simon Dedman, 2014-01-21 02:58 AM

bug1.png (184 KB) Simon Dedman, 2014-01-21 02:58 AM

bug2.png (167 KB) Simon Dedman, 2014-01-21 02:58 AM

2.0.1_works.png (183 KB) Simon Dedman, 2014-01-21 02:58 AM

CelticSampleVoronoi.shp (1.17 MB) Simon Dedman, 2014-01-22 12:36 PM

CelticCropNoNANoNegsSample.csv Magnifier (257 KB) Simon Dedman, 2014-01-22 12:36 PM

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Open to Feedback
  • Category changed from Browser to Symbology

I cannot confirm the issue (with both a CSV point layer and the derived vorony polygons) in QGIS master. Please attach sample data.

The "blank" column it is because now you can do categorized symbology using expression, anyway by choosing this blank attribute, then not using any expression and then and clicking "ok" is harmeless as the symbology remains the same (single symbol).

#2 Updated by Simon Dedman almost 6 years ago

Sample data attached.

Interesting about the blank column - thanks for the info, I assumed it was connected to this issue!

#3 Updated by Giovanni Manghi almost 6 years ago

Assuming that you are using the column "Average.Depth" to create the categorized symbology, then the "." in the column name is the culprit.

On qgis master/linux when using that column and the categorized symbology, then the classes are created but not applied.

If you edit the CSV and change the column name (Ex: "AD"), then all works as expected.

I'm not sure if dots are allowed in column names, if yes then it could be a qgis issue. If not then qgis should reject such layers.

#4 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to worksforme

it works as expected (even with the "." in the column name) on qgis master.

Also available in: Atom PDF