Bug report #9371

Paste Features as New Vector Layer/New Memory Vector layer fails with bigint column

Added by Nyall Dawson almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Jürgen Fischer
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17971

Description

The new "Paste Features As" doesn't correctly handle PostGIS layers with a bigint columns. Attempting to paste features with a bigint column results in the error:
"Cannot create field (int8,qlonglong)"

I've marked this as blocker since it's a new feature which isn't working as expected.

Associated revisions

Revision 22346cd3
Added by Jürgen Fischer almost 6 years ago

memory provider: add more native types (fixes #9371)

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Target version set to Future Release - High Priority
  • Category set to Vectors

#2 Updated by Jeremy Palmer almost 6 years ago

I also get a problem with int4 columns from a PostGIS source. Error is "Cannot create field id (int4,int)". PostGIS source table definition is:

CREATE TABLE parcels
(
id integer NOT NULL,
appellation character varying(2048),
affected_surveys character varying(2048),
parcel_intent character varying(100) NOT NULL,
topology_type character varying(100) NOT NULL,
statutory_actions character varying(4096),
land_district character varying(100) NOT NULL,
titles character varying(32768),
survey_area numeric(20,4),
calc_area numeric(20,0) NOT NULL,
shape geometry(Geometry,4167),
CONSTRAINT parcels_pkey PRIMARY KEY (id)
)
WITH (
OIDS=FALSE
);

#3 Updated by Jürgen Fischer almost 6 years ago

  • Assignee set to Jürgen Fischer

#4 Updated by Jürgen Fischer almost 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF