Bug report #9359

The WCS client don't seem to refresh the cache

Added by aperi2007 - about 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WCS
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17959

Description

Using the client wcs from last trunk,
I notice that the client wcs with the option "always-cache" use a local cached data .
And never update it.
I guess the local-cache should be update sometime.
I guess a acceptable strategy could be to update the cache on every use of the network option,
or however almost every day.
Because if a user set the use of "always-cache" it should never see any update to the data in wcs server.

Associated revisions

Revision 817f5a9a
Added by Larry Shaffer over 5 years ago

Fix #9359; set default WCS caching to Prefer Network

- This is noted in the tool tip, but was not set. Always Cache was the
default, which caused the cache to never be updated on upstream changes.

Caveat: this does not fix projects with existing WCS layers.

History

#1 Updated by Markus Neteler over 5 years ago

I confirm this important issue in QGIS 2.4.0

#2 Updated by Larry Shaffer over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF