Bug report #9349

QGis Zonal Statistics Plugin NoData included in Calculations

Added by Jason Tokayer almost 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:C++ Plugins
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:17951

Description

I have an ESRI raster file (w001001.adf) with a NoData value of -32768 and otherwise non-negative data. I have a vector value of polygons. When I use the built-in Zonal Statistics Plugin, many of the returned results are negative. Some of the negative values are -32768, which i understand to mean that there was no raster data in the particular polygon. However, many of the negative values are not equal to -32768, which implies that the NoData value of -32768 is counted with the non-negative data values when Zonal Statistics is used. Attached is both the raster and vector data. Note in the vector data attributes I have already applied Zonal Statistics and saved new columns as prc7count, prc7sum and prc7mean.


Related issues

Related to QGIS Application - Bug report #9151: zonal stats gives wrong results when features are not ove... Closed 2013-12-02

History

#1 Updated by Jason Tokayer almost 6 years ago

Could not upload the files due to size limitations

#2 Updated by Paolo Cavallini almost 6 years ago

Why not adding a very small portion of the raster?

#3 Updated by Jürgen Fischer almost 6 years ago

  • Status changed from Open to Feedback

#4 Updated by Giovanni Manghi almost 6 years ago

  • Target version set to Version 2.2
  • Affected QGIS version changed from 2.0.1 to master

I can confirm the issue, and probably is also the same cause of this #9151

#5 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Also available in: Atom PDF