Bug report #9324

Regression: Inference lines in composer no longer appear

Added by Tim Sutton almost 6 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:Nyall Dawson
Category:Map Composer/Printing
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17931

Description

In master ( e745b2f ) there seems to be a regression in composer. The inference lines that were shown when moving objects around are no longer displayed. Tester on Linux 64bit Ubuntu 13.10.

no-inference-lines.mp4 (1.19 MB) Tim Sutton, 2014-02-13 07:02 PM

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Priority changed from Normal to Severe/Regression

#2 Updated by Nyall Dawson almost 6 years ago

Can you clarify this for me -- what exactly do you mean by inference lines? The snap lines?

#3 Updated by Tim Sutton almost 6 years ago

  • Status changed from Open to Closed

Yes the lines that appear when you move an object around on the layout to show if they are aligned.

I tested on OSX last night and it was working fine. Now I just tested on gnome and it is working normally again.

#4 Updated by Tim Sutton almost 6 years ago

  • Operating System deleted (Ubuntu Linux)
  • OS version deleted (13.10)
  • Status changed from Closed to Reopened
  • File no-inference-lines.mp4 added

Hi

I am reopening this issue - there are still cases where no inference lines are show. I am attaching a short screencast that illustrates this (filmed against dae8ea66a169db7539a08dc81d2ebe9dab789f37). The issue seems to appear when opening an existing template - when creating a new template from scratch the inference lines work normally.

Replicated on OSX in the attached screencast.

#5 Updated by Nyall Dawson almost 6 years ago

Tim - can you confirm whether smart guides is enabled for this composition?

#6 Updated by Tim Sutton almost 6 years ago

Hi

Yes I can confirm they are enabled.

Regards

Tim

#7 Updated by Martin Dobias over 5 years ago

  • Priority changed from Severe/Regression to Normal

Lowering the priority - should not block the release.

#8 Updated by Nyall Dawson over 5 years ago

  • Status changed from Reopened to Feedback

Tim - is this still reproducible? If so, can you give me a few more details around how you trigger this issue? Specifically, is the composer created as a result of a plugin/python script?

#9 Updated by Tim Sutton over 5 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF