Bug report #9301

Impossible to open *.xls file from folder containing cyrillic

Added by dr - almost 4 years ago. Updated 28 days ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/OGR
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No

Description

It is possible to open MS Excel (*.xls) file as vector layer in QGIS. But if create folder with name containing cyrillic symbol, e.g. "куку" and put *.xls file into and try to open it - QGIS throws an error.

History

#1 Updated by Even Rouault about 1 year ago

The issue is in the Freexl library that uses ANSI file API, and not unicode ones.

#2 Updated by Giovanni Manghi 7 months ago

  • Easy fix? set to No
  • Regression? set to No

#3 Updated by Even Rouault 28 days ago

  • Resolution set to up/downstream
  • Status changed from Open to Closed

Also available in: Atom PDF