Bug report #9253

Regarding issue #8793... is not solved (OSM maps)

Added by Soren Lindqvist over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Browser
Affected QGIS version:2.0.1 Regression?:No
Operating System:Mac OSX Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:Yes Copied to github as #:17869

Description

Downloaded osm.bz2 for the countries of Portugal and Spain at "http://download.geofabrik.de/europe.html"
Successfully imported Topology from XML
Successfully exported Topology to SpatiaLite of polylines
Failed to export Topology to SpatiaLite of polygons: Can start the dialog and the process, after a while QGIS crashes.
When connecting to the db via Add SpatiaLite Layer, I choose the created layer, which is empty, attribute table has zero objects.
Both downloaded files has the exact same problem polylines works great but polygon crashes QGIS

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

The issue #8793 has been fixed in qgis master, if you are using qgis 2.0.1 (from the details of this ticket) then you are not using a version that includes the fix.

Please reopen if necessary.

PS
Please use meaningful subjects/titles when filing tickets, eventually referring to other tickets in the description.

#2 Updated by Soren Lindqvist over 5 years ago

My apologies, you need to use the developer version for it to work!

Thanks for the update, as I downloaded the latest version (stable) I though it was included.

Also available in: Atom PDF