Bug report #8793

Crash while Exporting OpenStreetMap Topology to SpatiaLite

Added by Gunnar Oehmichen almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Browser
Affected QGIS version:2.0.1 Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17494

Description

Downloaded osm.pbf file, converted to osm, extracted a region with osmosis and wanted to open the layers.
Successfully imported Topology from XML.
Successfully exported Topology to Spatiallite of points and polylines.
Failed to export Topology to Spatiallite of polygons: Can start the dialog and the process. After a while qgis crashes.
When connecting to the db via: Add Spatiallite Layer, i choose the created polygons layer, which is empty. Attribute table has zero objects.

History

#1 Updated by Martin Dobias almost 6 years ago

Could you please provide the input .osm file in order to reproduce the crash?

#2 Updated by Torsten Osigus almost 6 years ago

Hi,

me too.

QGIS Desktop 2.01 on Windows, Mac OS X (10.9) and Ubuntu 13.10 crashed when:

http://download.geofabrik.de/europe/germany/niedersachsen-latest.osm.pbf

convert with osmconvert to *.osm, imported Topology from XML and then exported Topology to Spatialite polygons. Changing Database-Labels (aka 1.000.000 or 1) to export doesn't help.

Points and Polylines worked.

Any help?

Thanks

Torsten Osigus

#3 Updated by Martin Dobias almost 6 years ago

Umm... the file has 180mb... Any chance for a smaller dataset that exhibits the crash? (I have currently slow and bad connection)

#5 Updated by Martin Dobias almost 6 years ago

Export of polygons from Bremen-latest works for me without any crashes.

#6 Updated by Torsten Osigus almost 6 years ago

With Niedersachsen-latest it doesn't work. Could yout test it with it?

#7 Updated by Matthias Kuhn almost 6 years ago

  • Status changed from Open to Closed

This has been fixed in 9259e27

Also available in: Atom PDF