Bug report #9222

WMTS being interpolated at native scale

Added by Jonathan Moules almost 8 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:17843

Description

1) Create a new project in EPSG:27700
2) Add WMTS http://maps.warwickshire.gov.uk/gs/gwc/service/wmts?REQUEST=GetCapabilities - looking at the "z_OS_vector_basemap" tileset
3) Go to Coventry, at scale 1:150,000.

The tile's being returned look like this:
http://maps.warwickshire.gov.uk/gs/gwc/service/wmts?SERVICE=WMTS&REQUEST=GetTile&VERSION=1.0.0&LAYER=z_OS_Vector_Basemap&STYLE=default&FORMAT=image/png&TILEMATRIXSET=UK_OSGB&TILEMATRIX=UK_OSGB:6&TILEROW=95&TILECOL=40

However, QGIS renders them like the attached. As you can see in the GetCapabilities, 1:150,000 is a native resolution for the tiles, so no interpolation/image modification is necessary, yet QGIS seems to be doing it anyway. This happens at all native resolutions as best I can tell.

Clipboard05.png (74.3 KB) Jonathan Moules, 2013-12-17 07:50 AM


Related issues

Related to QGIS Application - Bug report #6430: QGIS doesn't conform to WMS 1.3.0 resolution spec Closed 2012-09-28

History

#1 Updated by Jürgen Fischer almost 8 years ago

The tiles are 1:150000 at which resolution (note that QGIS scale is calculated on screen resolution, not on the arbitrary resolution in the WMS spec; see also #6430)?

#2 Updated by Jonathan Moules almost 8 years ago

Ok. The tiles are rendered at WMS spec resolution (so 90.7142367 dpi).
I get the premise of linked bug, however as OpenLayers (and any web-browser or image viewing app) can display the exact same tiles just fine on the exact same screen, I'm assuming there's a way for QGIS to do so. But that's heading well out of my depth.

#3 Updated by Jürgen Fischer almost 8 years ago

Jonathan Moules wrote:

Ok. The tiles are rendered at WMS spec resolution (so 90.7142367 dpi).
I get the premise of linked bug, however as OpenLayers (and any web-browser or image viewing app) can display the exact same tiles just fine on the exact same screen, I'm assuming there's a way for QGIS to do so. But that's heading well out of my depth.

Sure. But the 1:1 pixel mapping is not at 1:150000, but on a different scale.

#4 Updated by Jonathan Moules almost 8 years ago

Sorry if I'm missing something here, but the OpenLayers scale is 1:150,000 too.

I appreciate you're both using different pixel sizes, but is there a way to change the pixel size that QGIS uses, at least for OGC WMS requests?

#5 Updated by Jürgen Fischer almost 8 years ago

Jonathan Moules wrote:

I appreciate you're both using different pixel sizes, but is there a way to change the pixel size that QGIS uses, at least for OGC WMS requests?

No, the pixel size is a hardware setting.

And the scale reported in QGIS sets the real world size of an object in relation to the shown size on screen no matter what the pixel size / resolution of the used screen is. The WMS spec just defines some (more or less) common pixel size to make (approximate) scales available for configuration purposes, although it doesn't know for which actually resolution the images are going to be used (see also #6430).

#6 Updated by Jürgen Fischer over 7 years ago

  • Resolution set to duplicate

duplicate of #6430

#7 Updated by Jürgen Fischer over 7 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF