Bug report #9215

pgRouting + QGIS + Mac = headache

Added by Jonas Ohlund almost 8 years ago. Updated almost 8 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Python plugins
Affected QGIS version:2.0.1 Regression?:No
Operating System:Mac Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17838

Description

Hello GIS-Pros,

I really need your help!

I'm a real newbie so please forgive me if this is a stupid post but I couldn't find a solution anywhere. I'm studying Urban and Regional planning at Stockholm University and right now we're doing this GIS project. The university uses ArcGis to train us but since I would like to be able to improve my skills at home on a Mac, QGIS sounded like the perfect solution. Most of our teachers really promotes QGIS as a good alternative and we're allowed to use it for this project as long as we can make it work. After going through the pretty advanced installation process with some errors regarding the version of R which I sorted out eventually, I was thrilled to see QGIS working and I was feeling good about this project since I now would be able to do it on my own computer. So far, so good..

For this project we need to calculate shortest path and other basic network analysis stuff and we're using geodata from Swedish government institutions (shapefiles). So I installed pgRouting with 'brew install pgRouting' (I've tried a million ways but this seems to be the best since it automatically installs all the postgis/postgres stuff needed) and I've created the datebase, added the extensions and from QGIS I can access the db with dbmanager and add PostGIS layers from the local server. So far so good.

I have followed the instructions at both docs.pgrouting.org and workshop.pgrouting.org and I have managed to run the pgr_createTopology command which have been successful. I've also installed Psycopg2-2.4.5 and the pgRoutingLayer plugin in QGIS.

So far so good BUT when running select pgr_analyzeGraph('vagar', 0.00001, 'geom', 'id'); I get some kind of isring-error: See attached AnalyzeGraph.rtf

And when trying to click at the map with pgRoutingLayer I get a Python error: See attached pgRoutingLayer.rtf

I've also added two screenshot from QGIS DBManager if that might be helpful.

Nothing seems to work and I can't find anybody online with the same problem. You guys are my last hope. And I need to get going really fast with this project that is due to be handed in before Xmas. If I cant sort this out during the weekend I'll have to install parallels and run ArcGIS or use ArcGIS at school which would be sad..

I must have missed something right? Something really simple?

Many many thanks in advance! Contact me at: if you need further information to help me solve this.

Kind regards,
Jonas Öhlund
Stockholm University
Department of Human Geography

dbmanager.png (100 KB) Jonas Ohlund, 2013-12-15 08:43 PM

tableDBmanager.png (144 KB) Jonas Ohlund, 2013-12-15 08:43 PM

pgRoutingLayer.rtf (3.25 KB) Jonas Ohlund, 2013-12-15 08:43 PM

AnalyzeGraph.rtf (1.13 KB) Jonas Ohlund, 2013-12-15 08:43 PM

History

#1 Updated by Nathan Woodrow almost 8 years ago

  • Status changed from Open to Closed

This isn't the place to post stuff like this. You should only post bugs or feature request here.

The best place to ask a question like this on our mailing list (http://www.qgis.org/en/site/getinvolved/mailinglists.html#qgis-mailinglists) or http://gis.stackexchange.com/

Also available in: Atom PDF