Bug report #9143

Label Expression Dump program

Added by Lene Fischer almost 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17778

Description

Using weekly from 25.november.
Trying to make a label with expression - the program is dumped (close down)

25 students with different OS had the same experience
See video http://screencast.com/t/HzkII0ib

Markblok.zip (257 KB) Lene Fischer, 2013-11-30 07:23 AM

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Category changed from Browser to Labelling
  • Status changed from Open to Feedback
  • Target version set to Future Release - High Priority
  • Affected QGIS version changed from 2.0.1 to master

Hi,

it gives the same issue on qgis 2.0.1?

Can you attach sample data? I'm not able to replicate it on master/Linux.

Cheers!

#2 Updated by Lene Fischer almost 6 years ago

Data Attached
Regards
Lene Fischer

#3 Updated by Giovanni Manghi almost 6 years ago

Just tested qgis master 64bit installed with osgeo4w. No issues here. Maybe a plugin is the cause? can you please try with a clean installation? thanks.

#4 Updated by Lene Fischer almost 6 years ago

Hi Giovanni,
I´m using a total brand 'new' installation from weekly. And my studets the same.
Regards
Lene Fischer

#5 Updated by Giovanni Manghi almost 6 years ago

Lene Fischer wrote:

Hi Giovanni,
I´m using a total brand 'new' installation from weekly. And my studets the same.
Regards
Lene Fischer

using the standalone installer or osgeo4w?

#6 Updated by Jürgen Fischer almost 6 years ago

Giovanni Manghi wrote:

Lene Fischer wrote:

Hi Giovanni,
I´m using a total brand 'new' installation from weekly. And my studets the same.
Regards
Lene Fischer

using the standalone installer or osgeo4w?

All weeklies are standalone installer snapshots from osgeo4w.

#7 Updated by Giovanni Manghi almost 6 years ago

All weeklies are standalone installer snapshots from osgeo4w.

yes I know, I was trying to understand what can be the difference from their installation and mine. I can't replicate the issue.

#8 Updated by Larry Shaffer almost 6 years ago

I can not reproduce crash with 2.0.1 release on Mac.

Lene, do you have a custom Python expression function that is being loaded?

#9 Updated by Lene Fischer almost 6 years ago

  • Status changed from Feedback to Closed

Hi
Now we have all updated to the 2. december version - and now it works.
We also enconutered that we were unable to calculate in the fieldcalculator. So decided to take a newer version.
At first my students mumbled at bit- but seeing that a program can be fixed to fast - they were impressed.

Living (giving lectures) on the edge is no problem in an organisation like this. Thanks!!!
Lene Fischer

Also available in: Atom PDF