Bug report #9141

processing script editor window does not have close button on linux

Added by Richard Duivenvoorde over 6 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:Alexander Bruy
Category:Processing/Core
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:17776

Description

see subject: on linux the script editor does not have a close icon with me.

only way to close the editor window is alt-F4

on windows there is a nice close button.... see screenshots attached

linux.png (306 KB) Richard Duivenvoorde, 2013-11-29 06:35 AM

windows.png (150 KB) Richard Duivenvoorde, 2013-11-29 06:43 AM

linux-ob.png (58.9 KB) Alexander Bruy, 2013-12-04 11:36 PM

33.png (295 KB) Richard Duivenvoorde, 2013-12-05 12:48 PM

History

#1 Updated by Richard Duivenvoorde over 6 years ago

  • File deleted (windows.png)

#2 Updated by Richard Duivenvoorde over 6 years ago

#3 Updated by Alexander Bruy over 6 years ago

  • Assignee changed from Victor Olaya to Alexander Bruy
  • Status changed from Open to In Progress

This is strange, because I have close button under Linux (screenshot attached) with OpenBox. Maybe this is related to different WM/DE?

BTW, can some one move this ticket to Processing bugtracker?

#4 Updated by Alexander Bruy over 6 years ago

#5 Updated by Alexander Bruy over 6 years ago

  • Status changed from In Progress to Feedback

Should be fixed in e1186f164d. Please test.

#6 Updated by Richard Duivenvoorde over 6 years ago

Well, I have a close button in the titlebar now :-)

see screenshot

if you now could explicitly set this buttons, can you maybe also have a look at
#8699
because this looks like a similar problem, only explicitly unsetting this button

I think this one can be closed then

#7 Updated by Salvatore Larosa over 6 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed/implemented

#8 Updated by Giovanni Manghi about 5 years ago

  • Category changed from 94 to Processing/Core

Also available in: Atom PDF