Bug report #9128

wrong perimeter value in the identify feature tool

Added by robert vech over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:High
Assignee:-
Category:-
Affected QGIS version:2.0.1 Regression?:No
Operating System:qgis desktop Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:17765

Description

trying to calculate area and perimeter from a simple shapefile with CRS WGS84UTM32 following these steps:
1) set up the CRS of the project to WGS84UTM32 (on the fly transformation is checked)
2) load the shapefile
3) click on it with the identifier tool (identify features) I obtain:
- area: 19.321 km2
- perimeter: 0.221 m (!!!!)

then I modify the general CRS settings for new project (settings --> options) to WGS84UTM32 and, after reloading qgis, I did steps 1, 2 again and I obtained:
3bis) in the identify tool:
- area: 19.321 km2
- perimeter: 20.392 km

The second couple of results seems better! It seems that part of the identify tool use the CRS of the project (area) and part the general settings (perimeter). I added a sample test.

I sign it with high priority because is a very annoying bug when someone try to present qgis to new users ...

sample.zip - shapefile sample and screenshot (334 KB) robert vech, 2013-11-27 12:29 AM

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

Similar issues (but with the area in the field calculator) have been already fixed in qgis master, and in fact I can't replicate this issue.

Please give a try with qgis master and report back if it does not work for you.

Cheers!

Also available in: Atom PDF