Bug report #9106

There is no equivalent to setGrayBand for QgsSingleBandPseudoColorRenderer

Added by aaron davis almost 7 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Rasters
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:17749

Description

I have been struggling with multiband rasters for some time. I wish to iterate through the multiband raster that I have (30 bands), with the same colour stretch applied on each band. From the command line, since I am planningg to automate this. It used to be that, when I wanted to render a raster in pseudocolour, there was an attribute names setGrayBandName. This no longer exists for QGIS 2.0. If you set a raster to SingleBandGray, then there is an attribute for setGrayBand, and it refreshes after you change it and trigger a repaint of the raster. However, there is no facility for this in the QgsSingleBandPseudoColorRenderer! Am I missing something obvious? It seems to me that this must be a bug since, if you do this through the Layer Propoerties window, change the band, close tha window and open it again, there is no saved band in the band dropdown selector. The default is automatically band 01.

History

#1 Updated by Jürgen Fischer about 6 years ago

  • Category set to Rasters

#2 Updated by Nyall Dawson almost 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Also available in: Atom PDF