Bug report #9034

Symbol not visible in TOC when size is set in data defined properties

Added by Luca Lanteri over 6 years ago. Updated almost 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:17689

Description

On Qgis 2.0, when the point simbol size is set in "data defined properties" the simbol is no more diplayed in TOC.

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Open to Feedback

it means that in 1.8 used to work?

#2 Updated by Luca Lanteri over 6 years ago

I don't know. I haven't got a qgis 1.8 installed yet in order to test it.

#3 Updated by Nathan Woodrow over 6 years ago

  • Operating System deleted (Windows)
  • OS version deleted (XP)

Giovanni Manghi wrote:

it means that in 1.8 used to work?

No this is a new 2.0 feature.

#4 Updated by Mathieu Pellerin - nIRV over 6 years ago

Legend symbol has indeed never worked with data defined symbology. I feel it's not a bug but rather a lack in implementation.

IMO, there's an easy low cost implementation to dramatically improve behavior for the short term: have legend symbol revert to non data defined values when drawing. ie, if we have a data defined color fill, instead of showing a black color, it picks up the color defined in symbol fill color.

Same goes for size values, border colors, etc.

That would at least prevent rendering legend symbol useless, as is the case atm.

#5 Updated by Tudor Bărăscu almost 6 years ago

  • Target version set to Future Release - Lower Priority

I also just encountered this problem in 2.2 and master.

#6 Updated by Giovanni Manghi almost 6 years ago

  • Status changed from Feedback to Open
  • Affected QGIS version changed from 2.0.1 to master

#7 Updated by Martin Dobias almost 6 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

Duplicate of #8118

#8 Updated by Jürgen Fischer almost 6 years ago

  • Subject changed from Simbol not visible in TOC when size is set in data defined properties to Symbol not visible in TOC when size is set in data defined properties

Also available in: Atom PDF