Bug report #9031

Area Calculation in QGIS 2 stable

Added by Rhenriques Henriques about 7 years ago. Updated about 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:17686

Description

In QGIS2 (stable version, MacOSX Mavericks), the calculation of the area of objects within a polygon layer seems to be wrong.
Both project and Layer have UTM29N/WGS84 CRS. By opening the attributes table, activate edit, open field calculator, make a new field, choose Integer real and calculate area with "$area", results have nothing to do with the object geometry properties. Version 2.1 beta seems to calculate the area just fine.
Example project and data attached.
Cheers

TestAreaCalculation.zip (5.32 KB) Rhenriques Henriques, 2013-11-07 03:18 PM

History

#1 Updated by Giovanni Manghi about 7 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Hi Rui,

yes it is a known issue in qgis 2 when OTFR is ON and already fixed in master. Cheers!

Also available in: Atom PDF