Bug report #9028

PyQGIS cookbook docu on website mismatch api

Added by Luigi Pirelli about 7 years ago. Updated over 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Documentation and Help
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:17683

Description

here:
http://www.qgis.org/en/docs/pyqgis_developer_cookbook/loadlayer.html#raster-layers

the code:
rlayer = QgsRasterLayer(uri, 'my_wcs_layer', 'wcs')

doesn't work due to mismatch with api that accept uri QString as stated in api signature:

QgsRasterLayer( const QString & uri,
const QString & baseName,
const QString & providerKey,
bool loadDefaultStyleFlag = true );

History

#1 Updated by Alexander Bruy over 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Seems fixed in documentation master

Also available in: Atom PDF