Bug report #9027

Import vector to GeoServer not working

Added by Sean O'Donnell about 6 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17682

Description

I am having trouble getting a vector onto GeoServer using the Processing Toolbox (Formerly SEXTANTE) tool 'Import vector into GeoServer'. The tools works if I use a local host URL, however I am trying to upload onto our company's secure server. Also when I try to run on the actual server which changes the URL to 'http://localhost:8080/geoserver/rest' it still does not work. I am using the correct passcode and username, could there be some setting I have to make in GeoServer that allows this tool to run even on a secure server?

Here is the error I am getting: 
File "C:/Users/user/.qgis//python/plugins\\sextante\\core\\GeoAlgorithm.py", line 145, in execute
self.processAlgorithm(progress)
File "C:/Users/user/.qgis//python/plugins\\sextante\\admintools\\ImportVectorIntoGeoServer.py", line 54, in processAlgorithm
workspace = self.catalog.get_workspace(workspaceName)
File "C:/Users/user/.qgis//python/plugins\\sextante\\admintools\\geoserver\\catalog.py", line 517, in get_workspace
candidates = [w for w in self.get_workspaces() if w.name == name]
File "C:/Users/user/.qgis//python/plugins\\sextante\\admintools\\geoserver\\catalog.py", line 513, in get_workspaces
description = self.get_xml("%s/workspaces.xml" % self.service_url)
File "C:/Users/user/.qgis//python/plugins\\sextante\\admintools\\geoserver\\catalog.py", line 165, in get_xml
raise FailedRequestError("Tried to make a GET request to %s but got a %d status code: \
%s" % (url, response.status, content))
FailedRequestError: Tried to make a GET request to <function url at 0x0984EA30> but got a 404 status code:
<html><head><title>Apache Tomcat/6.0.20 - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 404 - </h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u></u></p><p><b>description</b> <u>The requested resource () is not available.</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/6.0.20</h3></body></html>

QGIS Version: 1.8 Lisboa & 2.0 Dufour (alothough I have tried it on 2.0 as well and had the same error)
Apache Tomcat: 6.0
URL: http://company.co.uk:8080/geoserver/rest
user: admin
password: xxxxxx
Layer to Import: map.shp
workspace: files

Any help would be greatly appreciated.

Thank you!

History

#1 Updated by Giovanni Manghi about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority

#2 Updated by Alexander Bruy almost 5 years ago

  • Status changed from Open to Closed

As I can see there is no such algorithm in Processing anymore. If I'm not wrong it was moved to OpenGeo plugin

#3 Updated by Giovanni Manghi over 4 years ago

  • Category changed from 94 to Processing/Core

Also available in: Atom PDF