Bug report #8963

Composer Map extents loss of precision in project file

Added by Nathan Woodrow about 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:2.0.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:17627

Description

Saving a project with a composer map in a composer results in a loss of precision in the extents. When the project is reloaded the extents are changed which changes the scale resulting in incorrect maps.

Example Extent:

385683.117

Saved as:

385683

This seems to be caused by using QString::number when saving the extents. Using QString::number(extent, "g", 10) saves the correct extents.

Associated revisions

Revision e614a095
Added by Nathan Woodrow about 6 years ago

Save precision correctly for composer map. Fix #8963

History

#1 Updated by Anonymous about 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF